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iOS・iPadOS端末のHybrid MDM・Apple MDM、macOS端末、tvOS端末のご利用にあたり取得したAPNs証明書の有効期限は、取得から1年間となります。
有効期限が切れた場合、登録済みの端末へのジョブを実行することができなくなりますので、期限が切れる前に更新する必要があります。
この手順は手順の動画もご用意しておりますので、ぜひご視聴ください。
【動画目次】
0:00 事前準備
1:08 管理画面のUIバージョン確認
2:48 APNs証明書の更新
11:01 更新時のエラー例①
14:27 更新時のエラー例②
15:24 管理設定について
★動画をご視聴いただいた方へ★
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※アンケートは匿名となり、所要時間は1分程度となります。
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目次
- ご用意いただくもの
- APNs証明書の更新を実行できる管理者について
- APNs証明書を更新する
- 「Create a Certificate」のみの画面が出る・Apple Accountが不明な場合
- 発行済みの証明書が複数ある場合
- エラーが表示され更新できない場合
- エラー:APNs証明書ファイル登録された証明書のAPSP番号が前回のものと異なります。証明書の再発行ではなく、証明書の更新を実施してください。
- エラー:APNs証明書ファイル登録しようとした証明書は無効です。「Apple Push Certificates Portal」で取得した証明書を登録してください。
- エラー:APNs証明書ファイル登録しようとした証明書は発行したCSRと一致しません。正しいCSRファイルを使用して証明書の更新を実施してください。]
- エラー:APNs証明書ファイル登録しようとした証明書の有効期限が切れています。
- APNs証明書の更新時のよくあるお問い合わせ・トラブル対応フローチャート
ご用意いただくもの
- PCにてApple Push Certificates Portalにアクセスするブラウザ
(対応ブラウザ:Safari、Google Chrome、Firefox、Microsoft Edge)
※Internet Explorerは使用できません - APNs取得時に使用したApple Account ※APNs証明書更新時のApple Accountについて参照
APNs証明書更新時のApple Accountについて
APNs証明書の更新は、APNs証明書を取得した際に使用したApple Accountが必要です。
異なるApple Accountを使用して、APNs証明書を更新することはできません。
APNs証明書を取得した際のApple Accountがわからない場合はApple Accountが不明な場合をご確認のうえ、Apple社へお問い合わせください。
取得した際に使用したApple Accountではなく、異なるApple Accountを使用して取得した証明書にて上書き更新を行うことも可能です。ただし、全端末にてApple MDMプロファイルの削除、および再インストール(もしくは端末初期化のうえ再登録)が必要となりますので、ご注意ください。
異なるApple Accountを使用して取得した証明書を使った上書き更新をご希望の場合は、以下サポート窓口までご連絡ください。
<mobiconnectサポート窓口>
メールアドレス:support-ja@mobi-connect.net
受付時間:平日10:00-18:00(土・日・祝祭日及び当社が定める休業日除く)
APNs証明書の更新を実行できる管理者について
APNs証明書の更新は以下の条件を満たした管理者のみ実行が可能です。
サービス利用権限で「APNs証明書管理」の権限が付与されていない場合や下位グループへのアクセスが制限されている場合、ルートグループに所属する管理者であっても「APNs証明書」のメニューが表示されないためご注意ください。
- ルートグループに所属している
- サービス利用権限で「APNs証明書管理」の権限が付与されている
- サービス利用権限で「下位グループへのアクセス制限」が「制限しない」になっている
APNs証明書を更新する
- サイドナビの「外部サービス連携」>「APNs証明書」を選択します。
※「APNs証明書」が表示されていない場合、ログインしている管理者にAPNs証明書を更新する権限がありません。APNs証明書の更新を実行できる管理者についてを確認し、必要な権限を適用するか、権限がある管理者で実行してください。 - 「APNs証明書を更新」をクリックします。
- 証明書要求ファイル(CSR)をダウンロードします。
※ダウンロードした要求ファイルは開かないでください。
※ファイルを開いた場合は破棄し、再度ダウンロードしてください。 - 「Apple Push Certificates Portal」をクリックし、Apple Push Certificates Portal (https://identity.apple.com/pushcert/) へアクセスします。
Mac PCまたはWindows PC、ブラウザは、Firefox、Safari、Google Chrome、Microsoft Edgeをご使用ください。Internet Explorerは使用できません。
※前回使用したApple Accountの「」をクリックすると、Apple Accountがクリップボードにコピーされます。
- APNs取得時に使用したApple Accountを入力し、(→)をクリックします。
- パスワードを入力し、サインインします。
- 使用中の証明書にて「Renew」ボタンをクリックします。
※以下の画面ではなく、「Create a Certificate」ボタンのみの画面が出る場合は、サインインするApple Accountが誤っており、更新が行えません。「Create a Certificate」のみの画面が出る・Apple Accountが不明な場合を参照してください。
※複数の証明書が表示され、使用中の証明書が不明の場合は「発行済みの証明書が複数ある場合」を参照してください。 - 「ファイルを選択」をクリックし、手順3でダウンロードした証明書要求ファイル (ファイル名「“アカウントID”.txt」)を選択し、「Upload」ボタンをクリックします。
※Notesは任意入力です。 - 次画面にて、「Download」をクリックすると、「MDM_ INVENTIT INC._Certificate.pem」という名前のファイルがダウンロードされます。
- mobiconnectの管理画面に戻り、「ファイルの選択」をクリックし、手順9で取得したAPNs証明書を選択します。
- 「登録」をクリックし、APNs証明書の更新は完了です。
- 更新完了後、APNs証明書の有効期限が更新されていることをご確認ください。
- 「管理設定」には、「Apple Push Certificates Portal」にサインインした「Apple Account」の登録や、APNs証明書の有効期限が近づいた際に通知を行う、有効期限通知先メールアドレスの登録が行えます。
未登録の場合は、右上「編集」よりご登録ください。
APNs証明書を失効後に更新した場合
すでにAPNs証明書の有効期限が切れている状態で更新を実施した場合、APNs証明書を更新後、反映までに最大24時間掛かる場合があります。
「Create a Certificate」のみの画面が出る・Apple Accountが不明な場合
Apple Push Certificates Portalで発行済みの証明書が表示されず、「Create a Certificate」のみ表示される場合は、昨年とは異なるApple Accountでサインインしており、更新は行えません。
APNs証明書更新時のApple Accountについてのとおり、APNs証明書の更新は、"昨年利用したApple Account"でApple Push Certificates Portalにサインインして行う必要があります。
今一度、昨年サインインに利用したApple Accountをご確認ください。
"昨年利用したApple Account"がわからない場合
mobiconnect管理画面>サイドナビの「外部サービス連携」>「APNs証明書」を開き、「APNs証明書詳細」に記載されている「サブジェクトDN」・「シリアル番号」情報をお控えのうえで、APNsのサービス提供元であるApple社(Appleプッシュ通知サービスの証明書に関するAppleへのお問い合わせ(Apple社サイト))へお問い合わせください。
発行済みの証明書が複数ある場合
Apple Push Certificates Portalで発行済みの証明書が複数表示され、現在使用中の証明書がどの証明書か不明な場合は、"Expiration Date"にて、有効期限をご確認ください。
有効期限が同一で、どの証明書か不明な場合は、証明書の「」をクリックし、「Serial Number」「Subject DN」をご確認ください。mobiconnectに登録済みのAPNs証明書の情報と一致するものがあれば、現在使用中の証明書として判断することが可能です。
エラーが表示され更新できない場合
表示されるエラー内容によって原因、対処方法が異なります。
エラー:APNs証明書ファイル登録された証明書のAPSP番号が前回のものと異なります。証明書の再発行ではなく、証明書の更新を実施してください。
原因
登録済みのAPNs証明書と異なるAPSP番号のAPNs証明書(PEM)が選択されています。
APNs証明書ファイルには、固有の番号である「APSP番号」が付与されており、更新時は、"昨年と同一のAPSP番号"の証明書ファイルを選択する必要があります。
対処方法
1)mobiconnect管理画面上の登録済みのAPNs証明書の「サブジェクトDN」を確認してください。
2)Apple Push Certificates Portalの「i」をクリックして表示される「Subject DN」が、1と一致する証明書レコードを探してください。一致した証明書レコードが、"昨年と同一のAPSP番号"の証明書です。
3)2で確認した証明書レコードの「Renew」から取得したAPNs証明書で、あらためて更新を行ってください。
Apple Push Certificates Portal画面に、mobiconnect管理画面の「サブジェクトDN」と一致する証明書レコードがない場合
2の手順で探しても証明書レコードがない場合は、"昨年APNs証明書を取得/更新した時とは別のApple Account"でApple Push Certificates Portalにサインインしていると考えられます。今一度、"昨年利用したApple Account"を確認してください。
"昨年利用したApple Account"が不明な場合
"昨年利用したApple Account"がわからない場合は、mobiconnect管理画面の「サブジェクトDN」・「シリアル番号」情報をお控えのうえで、Appleプッシュ通知サービスの証明書に関するAppleへのお問い合わせ(Apple社サイト)へお問い合わせください。
エラー:APNs証明書ファイル登録しようとした証明書は無効です。「Apple Push Certificates Portal」で取得した証明書を登録してください。
原因
選択しているファイルがAPNs証明書(PEM)ではありません。
対処方法
手順9で取得したAPNs証明書(「MDM_ INVENTIT INC._Certificate.pem」)を選択してください。
エラー:APNs証明書ファイル登録しようとした証明書は発行したCSRと一致しません。正しいCSRファイルを使用して証明書の更新を実施してください。]
原因
別の要求ファイル(CSR)で作成されたAPNs証明書が選択されています。
対処方法
手順3でダウンロードした正しい要求ファイル(CSR)を使って取得したAPNs証明書を選択してください。
エラー:APNs証明書ファイル登録しようとした証明書の有効期限が切れています。
原因
選択しているAPNs証明書の有効期限が更新されていません。
対処方法
手順3以降の操作を再度実施し、有効期限が更新されたAPNs証明書を選択してください。